Uploaded image for project: 'Beaker'
  1. Beaker
  2. BKR-1464

beaker-aws: update from aws-sdk-v1 to aws-sdk (v2)

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Blocker
    • Resolution: Fixed
    • None
    • None
    • None
    • None
      • existing test suites pass
    • Bug Fix
    • beaker-aws updated to use the latest version of the aws-sdk, which removes the dependency on the old version of JSON.
    • Needs Assessment

    Description

      The aws-sdk-v1 gem as a ~> dependency on json 1.4, causing installation problems on newer rubies (e.g. 2.4, that has json 2) without a compiler.

      This is particularly a problem for beaker on the pdk, as the pdk neither ships a compiler, nor the ancient json version required by the aws-sdk-v1.

      Attachments

        Issue Links

          Activity

            People

              tim.sharpe Tim Sharpe
              david.schmitt David Schmitt
              Votes:
              2 Vote for this issue
              Watchers:
              8 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support