Uploaded image for project: 'Beaker'
  1. Beaker
  2. BKR-1651

Remove el-5 support and other bitrot in beaker CI

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Normal
    • Resolution: Fixed
    • None
    • None
    • None
    • None
    • Quality Engineering
    • 2
    • DevInfraOps 2020-05-13
    • Needs Assessment

    Description

      This is blocking Beaker CI runs.

      The el-5 redhat variants are past end of life and are unsupported. el-6 will reach EOL in 2020, as well. I think it makes sense to keep el-6 support for now, but el-5 shouldn't be used anywhere anymore. I was prompted to remove the el-5 support because it appears that the EPEL mirrors are being refactored away and are likely going to disappear soon, which makes it difficult to beaker to support the platform without hosting packages ourselves, which we are not likely going to do.

      Attachments

        Activity

          People

            Unassigned Unassigned
            brandon.high Brandon High
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support