Uploaded image for project: 'Beaker'
  1. Beaker
  2. BKR-1675

Update net-scp to version 3.0.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Depend on net-scp ( ~> 3.0).

      Show
      Depend on net-scp ( ~> 3.0).
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      net-scp upstream already moved to version 3.0.0 [1] and Beaker still depends on version 1.x (~> 1.2) [2].

      In Debian/Ubuntu the gemspec was patched to support version 2.x (~> 2.0) [3] and no issue was reported so far by the users. It'd be great if we can move to net-scp version 3.x.

      [1] https://rubygems.org/gems/net-scp/versions/3.0.0

      [2] https://github.com/puppetlabs/beaker/blob/master/beaker.gemspec#L48

      [3] https://salsa.debian.org/debian/puppet-beaker/-/blob/debian/master/debian/patches/patch-gemspec-for-autopkgtest.patch#L33

       

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            lucaskanashiro Lucas Kanashiro
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support