Uploaded image for project: 'Beaker'
  1. Beaker
  2. BKR-1678

install_puppet_from_gem_on fails on systems with rubygems >= 3.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: beaker-puppet
    • Labels:
      None
    • Template:
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      When calling install_puppet_from_gem_on on a system with rubygems >= 3.0 (e.g. Ubuntu 20.04) it fails with the following error:

      Failure/Error: install_puppet_from_gem_on(host, foss_opts)
      Beaker::Host::CommandFailure:
        Host 'testserver' exited with 1 running:
         gem install puppet -v '5.5.20' --no-ri --no-rdoc --no-format-executable
        Last 10 lines of output were:
              ERROR:  While executing gem ... (OptionParser::InvalidOption)
                  invalid option: --no-ri
              Did you mean?  no-force
      

      This is due to the --no-ri and --no-rdoc options being removed in rubygems 3.0.0. These options have been replaced with the --no-document option. This option has been available since 2.0.0.preview2.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ChrisR Chris Reeves
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support