Uploaded image for project: 'Community Package Repository'
  1. Community Package Repository
  2. CPR-240

AIX: puppet-agent 1.2.6.214 doesn't properly setup puppet subsystem

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2017/08/02
    • Component/s: None
    • Labels:
      None
    • Template:

      Error rendering 'issue-templates-customfield'. Please contact your Jira administrators.

    • Story Points:
      2
    • Sprint:
      RE 2015-10-21

      Description

      Upon package installation, the puppet subsystem is created with the following attributes:

      [0] [AIX] root@pe-aix-61-agent:/etc # lssrc -s puppet -S
      #subsysname:synonym:cmdargs:path:uid:auditid:standin:standout:standerr:action:multi:contact:svrkey:svrmtype:priority:signorm:sigforce:display:waittime:grpname:
      puppet::/opt/puppetlabs/bin/puppet agent --no-daemonize:/opt/puppetlabs/puppet/bin/ruby:0:0:/dev/console:/dev/console:/dev/console:-O:-Q:-K:0:0:20:0:0:-d:20::
      

      Note that signorm and sigforce are both set to 0. This means that stopsrc -s puppet will time out when we try to stop the puppet service. As seen in https://github.com/puppetlabs/vanagon/blob/master/templates/rpm/project.spec.erb#L147, they should be set to 15 and 9, but something is preventing this from happening in the postrun.

        Attachments

          Activity

            People

            Assignee:
            stahnma Michael Stahnke
            Reporter:
            whopper William Hopper
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support