Affects Version/s: None
Fix Version/s: 2017/08/02
Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686 athlon i386 GNU/Linux
I have puppetmaster-passenger 3.8.4-1puppetlabs1 installed on Ubuntu 12.04. Also I need to install r10k to facilitate module management.
r10k needs /usr/bin/ruby to point to ruby version 1.9.3 in order to work.
That make /etc/apache2/mods-available/passenger.conf to use Ruby 1.9.x as well, which automatically break passenger modules as they are installed under 1.8 version.
The solution is to explicitly state ruby version 1.8 in config file.