Uploaded image for project: 'Community Package Repository'
  1. Community Package Repository
  2. CPR-265

Explicitly state Ruby version in puppetmaster-passenger configuration

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2017/08/02
    • Component/s: None
    • Labels:
      None
    • Environment:

      Ubuntu precise
      Linux 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 22:19:09 UTC 2012 i686 athlon i386 GNU/Linux

    • Template:

      Error rendering 'issue-templates-customfield'. Please contact your Jira administrators.

    • Team:
      Release Engineering
    • Sub-team:

      Description

      I have puppetmaster-passenger 3.8.4-1puppetlabs1 installed on Ubuntu 12.04. Also I need to install r10k to facilitate module management.

      r10k needs /usr/bin/ruby to point to ruby version 1.9.3 in order to work.
      That make /etc/apache2/mods-available/passenger.conf to use Ruby 1.9.x as well, which automatically break passenger modules as they are installed under 1.8 version.

      The solution is to explicitly state ruby version 1.8 in config file.

      <IfModule mod_passenger.c>
      PassengerRoot /usr
      PassengerRuby /usr/bin/ruby1.8
      </IfModule>

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            gasparch Gaspar
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support