Uploaded image for project: 'Community Package Repository'
  1. Community Package Repository
  2. CPR-273

rebuilding puppet-agent fails

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 2017/08/02
    • Component/s: None
    • Labels:
      None
    • Template:

      Error rendering 'issue-templates-customfield'. Please contact your Jira administrators.

    • Sub-team:

      Description

      Rebuilding puppet-agent fails because facter tries to create a symlink, but it already exists (see below error). I think vanagon should remove /opt/puppetlabs before starting the build.

      [100%] Built target libfacter_test
      make[2]: Leaving directory `/var/tmp/tmp.xTFJUdRBRI/facter'
      /opt/pl-build-tools/bin/cmake -E cmake_progress_start /var/tmp/tmp.xTFJUdRBRI/facter/CMakeFiles 0
      /usr/bin/make -f CMakeFiles/Makefile2 preinstall
      make[2]: Entering directory `/var/tmp/tmp.xTFJUdRBRI/facter'
      make[2]: Nothing to be done for `preinstall'.
      make[2]: Leaving directory `/var/tmp/tmp.xTFJUdRBRI/facter'
      Install the project...
      /opt/pl-build-tools/bin/cmake -P cmake_install.cmake
      -- Install configuration: "Release"
      -- Installing: /opt/puppetlabs/puppet/share/man/man8/facter.8
      -- Installing: /opt/puppetlabs/puppet/lib/libfacter.so.3.1.4
      -- Installing: /opt/puppetlabs/puppet/lib/libfacter.so
      -- Set runtime path of "/opt/puppetlabs/puppet/lib/libfacter.so.3.1.4" to "/opt/puppetlabs/puppet/lib"
      -- Up-to-date: /opt/puppetlabs/puppet/include/facter
      -- Installing: /opt/puppetlabs/puppet/include/facter/version.h
      -- Up-to-date: /opt/puppetlabs/puppet/include/facter/ruby
      -- Installing: /opt/puppetlabs/puppet/include/facter/ruby/ruby.hpp
      -- Up-to-date: /opt/puppetlabs/puppet/include/facter/logging
      -- Installing: /opt/puppetlabs/puppet/include/facter/logging/logging.hpp
      -- Up-to-date: /opt/puppetlabs/puppet/include/facter/util
      -- Installing: /opt/puppetlabs/puppet/include/facter/util/string.hpp
      -- Up-to-date: /opt/puppetlabs/puppet/include/facter/facts
      -- Up-to-date: /opt/puppetlabs/puppet/include/facter/facts/external
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/external/resolver.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/fact.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/array_value.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/vm.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/os_family.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/resolver.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/os.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/scalar_value.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/value.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/collection.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/facts/map_value.hpp
      -- Installing: /opt/puppetlabs/puppet/include/facter/export.h
      -- Installing: /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/facter.rb
      -- Installing: /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/facter.jar
      -- Installing: /opt/puppetlabs/puppet/bin/facter
      -- Set runtime path of "/opt/puppetlabs/puppet/bin/facter" to "/opt/puppetlabs/puppet/lib"
      make[1]: Leaving directory `/var/tmp/tmp.xTFJUdRBRI/facter'
      ln: failed to create symbolic link ‘/opt/puppetlabs/bin/facter’: File exists
      make: *** [facter-install] Error 1
      Remote ssh command ((cd /var/tmp/tmp.xTFJUdRBRI; /usr/bin/make)) failed on 'root@10.20.30.40'.
      /home/msg31/buildpuppet/ruby/lib/ruby/gems/2.3.0/gems/vanagon-0.5.0/lib/vanagon/utilities.rb:254:in `remote_ssh_command'
      /home/msg31/buildpuppet/ruby/lib/ruby/gems/2.3.0/gems/vanagon-0.5.0/lib/vanagon/engine/base.rb:24:in `dispatch'
      /home/msg31/buildpuppet/ruby/lib/ruby/gems/2.3.0/gems/vanagon-0.5.0/lib/vanagon/driver.rb:86:in `run'
      /home/msg31/buildpuppet/ruby/lib/ruby/gems/2.3.0/gems/vanagon-0.5.0/bin/build:32:in `block in <top (required)>'
      /home/msg31/buildpuppet/ruby/lib/ruby/gems/2.3.0/gems/vanagon-0.5.0/bin/build:25:in `each'
      /home/msg31/buildpuppet/ruby/lib/ruby/gems/2.3.0/gems/vanagon-0.5.0/bin/build:25:in `<top (required)>'
      ../ruby/bin/build:23:in `load'
      ../ruby/bin/build:23:in `<main>'
      

        Attachments

          Activity

            People

            Assignee:
            stahnma Michael Stahnke
            Reporter:
            pyther Matthew Gyurgyik
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support