Uploaded image for project: 'Community Package Repository'
  1. Community Package Repository
  2. CPR-322

dependency issues when installing puppetserver on

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2017/08/02
    • Component/s: None
    • Labels:
      None
    • Environment:

      RHEL 6

    • Template:

      Error rendering 'issue-templates-customfield'. Please contact your Jira administrators.

    • Sub-team:

      Description

      Hi,

      Im stuck in a never ending loop. I am trying to install the puppet server software on my RHEL 6 machine. When i attempt to install the server rpm it's telling me there are dependency issues with puppet agent and I should install that. When I try to install the puppet agent software it tells me systemd is required.

      When I read the document online I read that the systemd file should be created by installing the puppet server. So I'm stuck and not sure how to proceed since both these file are having some dependency on one another.

      What is see installing the puppet server :

      [root@mastarke-lnx-v2 mastarke]# yum install puppetserver
      Loaded plugins: fastestmirror, product-id, refresh-packagekit, rhnplugin, security, subscription-manager
      This system is receiving updates from RHN Classic or RHN Satellite.
      Setting up Install Process
      Loading mirror speeds from cached hostfile
      Resolving Dependencies
      --> Running transaction check
      ---> Package puppetserver.noarch 0:2.2.1-1.el7 will be installed
      --> Processing Dependency: puppet-agent >= 1.3.0 for package: puppetserver-2.2.1-1.el7.noarch
      --> Processing Dependency: systemd for package: puppetserver-2.2.1-1.el7.noarch
      --> Processing Dependency: systemd for package: puppetserver-2.2.1-1.el7.noarch
      --> Running transaction check
      ---> Package puppet-agent.x86_64 0:1.3.5-1.el7 will be installed
      --> Processing Dependency: systemd for package: puppet-agent-1.3.5-1.el7.x86_64
      --> Processing Dependency: systemd for package: puppet-agent-1.3.5-1.el7.x86_64
      ---> Package puppetserver.noarch 0:2.2.1-1.el7 will be installed
      --> Processing Dependency: systemd for package: puppetserver-2.2.1-1.el7.noarch
      --> Processing Dependency: systemd for package: puppetserver-2.2.1-1.el7.noarch

      Packages skipped because of dependency problems:
      * puppet-agent-1.3.5-1.el7.x86_64 from puppetlabs-pc1
      puppetserver-2.2.1-1.el7.noarch from puppetlabs-pc1*

      What I see when installing the puppet agent :

      [root@mastarke-lnx-v2 mastarke]# rpm -ivh puppet-agent-1.3.5-1.el7.x86_64.rpm
      warning: puppet-agent-1.3.5-1.el7.x86_64.rpm: Header V4 RSA/SHA1 Signature, key ID 4bd6ec30: NOKEY
      error: Failed dependencies:
      systemd is needed by puppet-agent-1.3.5-1.el7.x86_64

        Attachments

          Activity

            People

            Assignee:
            mastarke Matthew Starkey
            Reporter:
            mastarke Matthew Starkey
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support