Uploaded image for project: 'Community Package Repository'
  1. Community Package Repository
  2. CPR-651

APT/YUM repositories should contain release package for next release to ease updates

    Details

    • Type: Improvement
    • Status: Ready for Engineering
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:

      Linux

    • Template:
    • Acceptance Criteria:
      • apt-get install puppet5-release works when puppetlabs-release-pc1 is already installed
      • apt-get install puppet6-release works when puppet5-release is already installed
      • dito for yum
    • Sprint:
      Release Engineering Hopper
    • QA Risk Assessment:
      Needs Assessment

      Description

      As I'm currently in the process of updating Puppet agents from 4.x to 5.x, I found that I need to manually download the release package for the new version. That wouldn't be required if the repository for the currently running release already contained it. I could then install it with a simple package resource, like

      package { 'puppet5-release':
        ensure => latest,
      }

      prior to updating puppet-agent itself.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              dhs@recommind.com Dirk Heinrichs
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:

                Zendesk Support