Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCUMENT-1230

Upgrade PE should say that you should have your internal agent tarballs downloaded before upgrading PE

    XMLWordPrintable

Details

    • Improvement
    • Status: Needs Information
    • Normal
    • Resolution: Unresolved
    • None
    • 2
    • Needs Assessment

    Description

      https://puppet.com/docs/pe/2019.8/upgrading_pe.html should mention somewhere that if you don't have Internet access, you should download and install agent tarballs from https://puppet.com/misc/pe-files/pe_repo/ per https://puppet.com/docs/pe/2019.8/installing_agents.html#install_nix_agents_no_internet on your internal mirror of https://pm.puppetlabs.com/puppet-agent/ (that is, the $base_path parameter of the pe_repo module) before upgrading. This is because the pe_repo module tries to download the agent tarballs during the upgrade. But if you don't know this is going to happen (because it doesn't say so on the Upgrading PE page), then that step of the PE upgrade fails, and you'll have to fix it then run the upgrade again. While you're fixing it, your agents will be contacting your primary server and trying to upgrade their agents (if you use the puppet_agent module with the version set to auto), which will also fail because you didn't have the agent tarballs in place beforehand. So it can save a lot of time if you prepare this ahead of time, which is why the Upgrading PE page should explain this a little bit.

      Attachments

        Activity

          People

            Unassigned Unassigned
            kenyon Kenyon Ralph
            Votes:
            0 Vote for this issue
            Watchers:
            6 Start watching this issue

            Dates

              Created:
              Updated:

              Zendesk Support