Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCUMENT-134

Call out in the docs that Puppet requires a multi-process rack server or webrick.

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Aspirational Aardvark 8.11.14

      Description

      This came up recently in PUP-2659, that someone was trying to run Puppet with Puma, which is a threaded rack server, and were hitting the context underflow issue since Puppet is not thread safe. We've isolated threads in Webrick, but not generally for rack servers.

      Puppet needs a multi-process rack server such as Passenger, Thin, Unicorn.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                nick.fagerlund Nicholas Fagerlund
                Reporter:
                joshua.partlow Joshua Partlow
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support