Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCUMENT-684

Sensitive data type page should call out which versions of PE and PuppetDB it works with

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Component/s: None
    • Labels:
    • Template:
    • QA Risk Assessment:
      Needs Assessment

      Description

      Background

      In PDB-3322, we learned that PuppetDB can't store the sensitive data type in versions less than 4.4.0.

      The issue was also resolved in PE 2016.4.4 and 2017.2.1.

      The Problem

      The sensitive data type page doesn't make mention of which versions it is compatible with.

      Suggested Solution

      This page https://docs.puppet.com/puppet/4.6/lang_data_sensitive.html starting with Puppet 4.6 up to current should state that PuppetDB has a known issue storing the sensitive data type and list minimum compatible versions of PuppetDB and PE to avoid any issues using the sensitive data type.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                jean Jean Bond
                Reporter:
                nick.walker Nick Walker
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support