Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCUMENT-902

Add information about "Warning: setting autosign is deprecated" to Known Issues for 2018.1.4

    Details

    • Template:
    • QA Risk Assessment:
      Needs Assessment

      Description

      PE 2018.1.4 displays the following Warning during a puppet agent run:

      Warning: Setting autosign is deprecated.
      {{ (location: /opt/puppetlabs/puppet/lib/ruby/vendor_ruby/puppet/settings.rb:1169:in `issue_deprecation_warning')}}

      This is warning us that with the new puppet ca that's going to be implemented, the autosign setting will be deprecated.

      The thing is, this feature isn't yet implemented, so there is nothing we can do about the warning.  What's worse, nothing about this warning and what to do about it can be found anywhere on the web site.

      I would like to request that information about this Warning be included in "Known Issues" for 2018.1.4 so that people wondering about the warning will know it can be safely ignored.

      Add-on feature request:  The ability to ignore / filter certain Warnings during puppet agent runs.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                michelle.fredette Michelle Fredette
                Reporter:
                rlawson_merrill Richard Lawson
              • Votes:
                1 Vote for this issue
                Watchers:
                7 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support