Uploaded image for project: 'Documentation'
  1. Documentation
  2. DOCUMENT-97

Add a note when upgrading using puppetlabs-puppetdb module to upgrade the module first

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Component/s: PuppetDB
    • Labels:
    • Environment:

      Puppet Open Source 3.6.0
      puppetdb 2.0.0

    • Template:
    • Story Points:
      1
    • Sprint:
      Busy Badger 8.25.14
    • UX Priority:
      Normal

      Description

      After upgrading to puppetdb 2.0.0, my setup seemed broken and I got Notice: Unable to connect to puppetdb server (puppet.koewacht.net:8081): [404] Not Found
      errors. This was due an old puppetdb mosule (1.2.1) is used to install puppetdb. It did work with every 1.x version of puppetdb, but is broken since 2.0.0.
      Puppetdb_conn_validator[puppetdb_conn] seems to use a v1 call to check if puppetdb is accessible.
      A simple note telleing people that puppetdb needs at least the puppetdb module version 3.x will help avoid this.
      affected page : http://docs.puppetlabs.com/puppetdb/2.0/upgrade.html#upgrading-with-the-puppetdb-module

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                justin.holguin Justin Holguin
                Reporter:
                johanOF Johan De Wit
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - 10 minutes
                  10m
                  Remaining:
                  Remaining Estimate - 10 minutes
                  10m
                  Logged:
                  Time Spent - Not Specified
                  Not Specified