Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: FACT 2.4.4
    • Fix Version/s: FACT 2.4.7, FACT 2.5.0
    • Component/s: Community
    • Labels:
      None
    • Environment:

      Running puppet on OpenBSD 5.8-amd64, while my router has no swap device.
      I did met with the problem with former versions of OpenBSD & facter.
      I assume it is also there, running up-to-date facter.

    • Template:
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Facter no longer returns an error message when swap is disabled on OpenBSD

      Description

      When loading facts on OpenBSD with no swap device defined, the swap fact returns a couple lines on stderr, such as:
      ```
      swapctl: no swap devices configured
      ```

        Attachments

          Activity

            People

            • Assignee:
              branan Branan Riley
              Reporter:
              syn syn
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support

                  Time Tracking

                  Estimated:
                  Original Estimate - 1 hour
                  1h
                  Remaining:
                  Remaining Estimate - 1 hour
                  1h
                  Logged:
                  Time Spent - Not Specified
                  Not Specified