Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-1348

Remove usage of win32-security gem in Facter 2.x

    Details

      Description

      As part of the work in PUP-5735 it was discovered that Facter uses the win32-security gem. This gem uses ANSI API calls and can cause issues with unicode characters. This ticket will port the required code from Puppet into Facter and then remove usage of the win32-security gem.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                ryan.gard Ryan Gard
                Reporter:
                glenn.sarti Glenn Sarti
                QA Contact:
                Ryan Gard
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support