Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-1425

Facter 3.1.7 incorrectly identifies itself as version 3.2.0

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: FACT 3.1.7
    • Fix Version/s: FACT 3.3.0
    • Component/s: Community
    • Labels:
      None
    • Template:
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Hide
      Docs folks: this is going to require a bit of a special comment. Perhaps something like this:

      Facter 3.1.7 and 3.1.8 both incorrectly identified themselves as Facter 3.2.0 - both with {{facter --version}} and with {{facter facterversion}}.

      To avoid adding to the confusion, facter will skip a facter 3.2.0 version - the next release will be (and will report itself as) facter 3.3.0.
      Show
      Docs folks: this is going to require a bit of a special comment. Perhaps something like this: Facter 3.1.7 and 3.1.8 both incorrectly identified themselves as Facter 3.2.0 - both with {{facter --version}} and with {{facter facterversion}}. To avoid adding to the confusion, facter will skip a facter 3.2.0 version - the next release will be (and will report itself as) facter 3.3.0.

      Description

      Facter 3.1.7 incorrectly identifies itself as version 3.2.0.

      Code build from the 3.1.7 release tarball on Github, facter-3.1.7.tar.gz (SHA256 ebb703068daaf6ff880be8d14898709ccea44288874450e25a887ecb0a5e04ae)

      $ facter facterversion
      3.2.0
      

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                schug Christoph Schug
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support