Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-1641

Remove win32console gem as a 32-bit Windows dependency from Facter 2.x series

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: FACT 2.4.6
    • Fix Version/s: FACT 2.5.0
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Agent
    • Story Points:
      1
    • Sprint:
      Agent 2017-05-31
    • QA Risk Assessment:
      No Action

      Description

      win32console gem was only needed for Puppet 3.x Windows 32-bit running on Ruby 1.9.3. The 3.x series agent for 64-bit removed the gem as it ran on Ruby 2.0.0.

      Even though this breaks backwards compatibility for 3.x agents, they are EOL, and there shouldn't be any 3.x based 32-bit Windows workflows that would be impacted.

      This is basically a tech-debt clean-up.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                ethan Ethan Brown
                QA Contact:
                Eric Delaney
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support