Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-1778

Puppet/Facter loading facts twice

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Fixed
    • FACT 3.6.0, FACT 3.6.7
    • FACT 3.6.8, FACT 3.9.3
    • None
    • None
    • Dumpling
    • Needs Assessment
    • Bug Fix
    • Facter 3.6 started evaluating custom facts from Puppet twice. Correct this to only load them once.
    • Needs Assessment

    Description

      Just went from Puppet 3.7.3 to Puppet 4.10.8

      I now see my custom facts load twice at the beginning of a Puppet run. I was told in #irc this was an expected behavior, that has been filed many times, but thats just how it is?

      Is there a reason for this, or a work around? This really messes up our entire environment as some servers can take up to 6 (sometimes 8 minutes) just to gather facts. These are large storage servers with sometimes 200 luns attached. In addition, some of our 730's and newer 930's have 16-24 ports in them, which are also ran through facter.

      This was not an issue for the last 4-5 years, but seems like there is no way around this? Is that a correct statement?

      Attachments

        Issue Links

          Activity

            People

              Unassigned Unassigned
              tek0011 Jeff Sparrow
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support