Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-182

Facter Does not run on OS X 10.9 Mavericks

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: FACT 1.7.4
    • Fix Version/s: FACT 1.7.5
    • Component/s: None
    • Labels:
      None
    • Template:

      Description

      If you install Facter 1.7.4 and earlier on OS X 10.9 Mavericks and try to run it, you get the following error:

      sh-3.2# facter
      /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require': cannot load such file – facter/application (LoadError)
      from /System/Library/Frameworks/Ruby.framework/Versions/2.0/usr/lib/ruby/2.0.0/rubygems/core_ext/kernel_require.rb:45:in `require'
      from /usr/bin/facter:14:in `<main>'

      This is the same issue we were running into with Puppet itself prior to version 3.4.x. The issue is that facter is still being installed into /usr/lib/ruby/site_ruby/1.8 and it should be installed into /Library/Ruby/Site instead. The reason this is necessary is because OS X 10.9 now uses Ruby 2.0 as its default.

      Until this is fixed, facter is broken on OS X 10.9 and won't function unless you cherry pick fixes to facter and roll your own installer.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  natewalck Nate Walck
                • Votes:
                  1 Vote for this issue
                  Watchers:
                  5 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support