Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-2260

remove deprecation of facter --puppet

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Resolved
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: FACT 3.14.8, FACT 3.11.12
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      Remove Deprecated: use `puppet facts` instead from facter help.

      Show
      Remove Deprecated: use `puppet facts` instead from facter help.
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      NW - 2020-01-22
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      facter --puppet no longer throws a deprecation warning.
    • QA Risk Assessment:
      Needs Assessment

      Description

      Help for facter --puppet states {{Deprecated: use 'puppet facts' instead)}

      Except FACT-96 was updated in 2015 with:

      We reversed course on the deprecation, at least until puppet facts offers full parity.

      puppet facts does not include many facter options (like, but not limited to --no-custom-facts) valuable for debugging, and some users avoid deprecated functionality in principle or policy.

      (The Release notes for Facter 3.0 that mentions facter -p has been restored have since aged out of our document tree, because 2015 < 2019.)

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              luchian.nemes Luchian Nemes
              Reporter:
              tom.kishel Thomas Kishel
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support