Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-2492

factern-ng has no fallback for unknown distro flavours

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: FACT 4.0.13
    • Component/s: Facter 4
    • Labels:
      None
    • Template:
    • Team:
      Night's Watch
    • Sub-team:
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      when running `facter` on my laptop, i get the following error:

      ERROR Facter::ClassDiscoverer - There is no module named Elementary

      this did not happen with facter 2 or 3:

      meena@76ix ~/s/p/puppetlabs-stdlib (master) [1]> env PDK_PUPPET_VERSION=4 pdk bundle exec facter --version
      pdk (INFO): Using Ruby 2.1.9
      pdk (WARN): Support for Puppet versions older than 5.0.0 is deprecated and will be removed in a future version of PDK.
      pdk (INFO): Using Puppet 4.10.12
      2.5.7
      meena@76ix ~/s/p/puppetlabs-stdlib (master)> env PDK_PUPPET_VERSION=4 pdk bundle exec facter os
      pdk (INFO): Using Ruby 2.1.9
      pdk (WARN): Support for Puppet versions older than 5.0.0 is deprecated and will be removed in a future version of PDK.
      pdk (INFO): Using Puppet 4.10.12
      {{{"name"=>"Debian", "family"=>"Debian", "release"=>

      {"major"=>"buster/sid", "full"=>"buster/sid"}

      , "lsb"=>{"distcodename"=>"hera", "distid"=>"elementary", "distdescription"=>"elementary OS 5.1.2 Hera", "distrelease"=>"5.1.2", "majdistrelease"=>"5", "minordistrelease"=>"1"}}}}

        Attachments

          Activity

            People

            Assignee:
            mihai.buzgau Mihai Buzgau
            Reporter:
            igalic Igor Galić
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support