Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-3027

Loosen the Ruby dependency to allow install on Ruby 3

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: FACT 4.2.0
    • Component/s: None
    • Labels:
    • Template:
    • Team:
      Night's Watch
    • Release Notes:
      Enhancement
    • Release Notes Summary:
      Allow facter gem to be installed on ruby 3
    • QA Risk Assessment:
      Needs Assessment

      Description

      Currently Facter 4 is locked to ruby 2 (~> 2.3) which does not allow installation on Ruby 3.

      Projects that depend of Facter and are installed on Ruby 3, will fetch Facter 2.5.7

      We should allow ruby >= 2.3

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            gheorghe.popescu Gheorghe Popescu
            Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support