Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-779

Facter --puppet fails silently with Puppet 4

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: FACT 2.3.0
    • Fix Version/s: FACT 2.4.0
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Platform Client 2015-01-21

      Description

      In commit a5363dd0 in Puppet, the deprecated parse_config class method was removed from Puppet. Facter still calls this method in lib/facter/application.rb for the --puppet flag. We should replace the usage of this deprecated method with Puppet's initialize_settings method.

        Attachments

          Issue Links

            Activity

              jsd-sla-details-panel

                People

                • Assignee:
                  Unassigned
                  Reporter:
                  whopper William Hopper
                • Votes:
                  0 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:

                    Zendesk Support