Uploaded image for project: 'Facter'
  1. Facter
  2. FACT-96

Deprecate 'facter --puppet'

    XMLWordPrintable

    Details

    • Type: Task
    • Status: Closed
    • Priority: Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: FACT 2.4.4
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Client 2015-05-27
    • Release Notes:
      New Feature

      Description

      facter --puppet introduces a circular dependency, since puppet already depends on facter. So let's deprecate facter --puppet and document/improve puppet facts find as a replacement.

      This is used in the pe_mcollective plugin so that would need an update:
      https://github.com/puppetlabs/puppetlabs-pe_mcollective/blob/master/templates/refresh-mcollective-metadata

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              kylo Kylo Ginsberg
              Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support