Uploaded image for project: 'Puppet Forge'
  1. Puppet Forge
  2. FORGE-181

errors in old releases prevent installation of working new releases

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Normal
    • Resolution: Duplicate
    • None
    • None
    • Major

    Description

      (master) bam:pkg$ sudo puppet module install ghoneycutt-puppet --version 2.10.0 -i /tmp/foo --debug

      Notice: Preparing to install into /tmp/foo ...
      Notice: Downloading from https://forgeapi.puppetlabs.com ...
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-puppet
      Debug: Error in ghoneycutt-puppet@2.1.2 parsing dependency puppetlabs-stdlib (Unparsable version range: ">= 3.2.x"); using empty range.
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-apache
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-ssh
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-stdlib
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-stdlib&limit=20&offset=20
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-common
      Debug: Error in ghoneycutt-common@1.0.0 parsing dependency puppetlabs-stdlib (Unparsable version range: ">= 3.2.x"); using empty range.
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=puppetlabs-firewall
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-pam
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-nsswitch
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-generic
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-backup
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-certs
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-dnsclient
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-facter
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-hosts
      Debug: HTTP GET https://forgeapi.puppetlabs.com/v3/releases?module=ghoneycutt-generic>= 1.0.0
      Error: bad URI(is not URI?): /v3/releases?module=ghoneycutt-generic>= 1.0.0
      Error: Try 'puppet help module install' for usage

      (master) bam:pkg$ grep -ri generic .
      (master) bam:pkg$

      This must be related to an old version, though it is keeping people from using new versions that should work.

      Attachments

        Issue Links

          Activity

            People

              ryan Ryan Coleman
              ghoneycutt garrett honeycutt
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support