Uploaded image for project: 'Puppet Forge'
  1. Puppet Forge
  2. FORGE-212

500 error when publishing a module without a valid version range

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      FORGE 2014-11-05

      Description

      originally reported here:
      http://ask.puppetlabs.com/question/14044/why-is-forgepuppetlabscom-giving-me-500-server-errors-on-package-upload/

      In this version of the metadata version is set to 0.06.7 which is an invalid module verison due to the leading 0 in the minor version.

      https://github.com/hesco/hesco-weave/commit/a6859b8a03336f4f6d6261076ec5eb55f8821716#diff-490694a9db8f7a371538da1abe484314

      This should be returning a 400 with helpful information rather then a 500.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                jesse Jesse Scott
                Reporter:
                alex Alex Dreyer
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: