Uploaded image for project: 'Hiera'
  1. Hiera
  2. HI-526

Ruby 1.9.3 and json_pure 2.0.2

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: HI 3.2.0
    • Fix Version/s: None
    • Component/s: None
    • Labels:
    • Environment:

      All using Ruby 1.9.3

    • Template:

      Description

      Hiera has a dependency on json_pure of >= 0: https://github.com/puppetlabs/hiera/blob/master/.gemspec

      json_pure 2.0.2 dropped support for Ruby 1.9.3, so installs of Hiera, and therefore also Puppet, now fail on environments with Ruby 1.9.3.

      Something needs to be added that restricts the version of json_pure to <= 2.0.1 if ruby is 1.9.3. I believe Kylo has mentioned to me in a PR that there are no plans to up the minimum ruby requirement for Puppet prior to 5.0, so I think this is the path of least resistance here.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            mis6541 Matt Schuchard
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support