Uploaded image for project: 'Hiera'
  1. Hiera
  2. HI-528

Remove json_pure dependency

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: HI 3.2.1
    • Component/s: None
    • Labels:
      None
    • Template:
    • Story Points:
      1
    • Sprint:
      Language 2016-08-10
    • Release Notes:
      Bug Fix
    • Release Notes Summary:
      Hiera 3.2.x does not support Rubies < 1.9.3. The dependencies on 'json' and 'json_pure' has therefore been dropped from hiera's gemspec to make it easier to consume hiera as a gem.

      Description

      json_pure was added as a dependency to hiera to enable easier development with ruby 1.8.7 (which doesn't include a json implementation). With hiera now supporting only ruby 1.9.3+, the dependency is no longer needed.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              kylo Kylo Ginsberg
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Zendesk Support