Uploaded image for project: 'Infrastructure Automation Content'
  1. Infrastructure Automation Content
  2. IAC-1582

Change in Facter.fact breaks unit tests in haproxy module

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Component/s: None
    • Labels:
      None
    • Template:
    • Acceptance Criteria:
      Hide

      AC Unit tests should run clean for haproxy module

      Show
      AC Unit tests should run clean for haproxy module
    • QA Risk Assessment:
      Needs Assessment

      Description

      The tests are passing with previous released version of facter 4.0.52 and it started failing from the latest release 4.1.0

       

      Error

       

      1) Facter::Util::Fact when haproxy is not present is expected to be nil
       Failure/Error: expect(Facter.fact(:haproxy_version)).to be_nil
      expected: nil
       got: #<Facter::ResolvedFact:0x00007feb9a7c28f0 @name="haproxy_version", @value=nil, @type=:core, @user_query=nil, @filter_tokens=[]>
       # ./spec/unit/facter/haproxy_version_spec.rb:26:in `block (3 levels) in <top (required)>'
      

       

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              gabriel.nagy Gabriel Nagy
              Reporter:
              sheena Sheena Tharakanparampil
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support