Uploaded image for project: 'Infrastructure Automation Content'
  1. Infrastructure Automation Content
  2. IAC-5 Modules CI Triage
  3. IAC-349

triage: acceptance tests failing during PE install

    XMLWordPrintable

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Normal
    • Resolution: Won't Fix
    • Component/s: None
    • Labels:
      None
    • Template:
    • QA Risk Assessment:
      Needs Assessment

      Description

        2019-12-14T16:43:23.513+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Pe_service[console-services]/Service[pe-console-services]: Skipping because of failed dependencies
        2019-12-14T16:43:23.515+00:00 - [Error]: Could not prefetch pe_node_group provider 'ruby': Failed to open TCP connection to pink-trustee.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "pink-trustee.delivery.puppetlabs.net" port 4433)
        2019-12-14T16:43:23.540+00:00 - [Error]: Failed to apply catalog: Failed to open TCP connection to pink-trustee.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "pink-trustee.delivery.puppetlabs.net" port 4433)
        * /opt/puppetlabs/puppet/bin/puppet infrastructure configure  --detailed-exitcodes --environmentpath /opt/puppetlabs/server/data/environments --environment enterprise --no-noop --install=2018.1.12-rc0-87-g0447d96   
        * returned: 1
        2019-12-14T16:43:24.702+00:00 [ERROR]: !! There were problems during the application of the installation catalog. !!
        2019-12-14T16:43:24.709+00:00 [ERROR]: !! Review the logs at /var/log/puppetlabs/installer/2019-12-14T16.43.02+0000.install.log and resolve any issues you can find. !!
        2019-12-14T16:43:24.713+00:00 [ERROR]: !! After fixing any errors, re-run the installer to complete the installation or upgrade. !!
        2019-12-14T16:43:24.717+00:00 Running command: /opt/puppetlabs/puppet/bin/puppet agent --enable
       
      pink-trustee.delivery.puppetlabs.net (redhat7-64-1) executed in 23.39 seconds
      Exited: 1
       
      An error occurred while loading ./spec/acceptance/tasks/init_spec.rb.
      Failure/Error: run_puppet_install_helper
      Beaker::Host::CommandFailure:
        Host 'pink-trustee.delivery.puppetlabs.net' exited with 1 running:
         cd /tmp/2019-12-14_16.43.01.8GRA0t/puppet-enterprise-2018.1.12-rc0-87-g0447d96-el-7-x86_64 && ./puppet-enterprise-installer -y -c /tmp/2019-12-14_16.43.01.8GRA0t/pe.conf
        Last 10 lines of output were:
        	2019-12-14T16:43:23.512+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Pe_service[console-services]/Exec[pe-console-services service full restart]: Skipping because of failed dependencies
        	2019-12-14T16:43:23.513+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Pe_service[console-services]/Service[pe-console-services]: Skipping because of failed dependencies
        	2019-12-14T16:43:23.515+00:00 - [Error]: Could not prefetch pe_node_group provider 'ruby': Failed to open TCP connection to pink-trustee.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "pink-trustee.delivery.puppetlabs.net" port 4433)
        	2019-12-14T16:43:23.540+00:00 - [Error]: Failed to apply catalog: Failed to open TCP connection to pink-trustee.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "pink-trustee.delivery.puppetlabs.net" port 4433)
        	* /opt/puppetlabs/puppet/bin/puppet infrastructure configure  --detailed-exitcodes --environmentpath /opt/puppetlabs/server/data/environments --environment enterprise --no-noop --install=2018.1.12-rc0-87-g0447d96   
        	* returned: 1
        	2019-12-14T16:43:24.702+00:00 [ERROR]: !! There were problems during the application of the installation catalog. !!
        	2019-12-14T16:43:24.709+00:00 [ERROR]: !! Review the logs at /var/log/puppetlabs/installer/2019-12-14T16.43.02+0000.install.log and resolve any issues you can find. !!
        	2019-12-14T16:43:24.713+00:00 [ERROR]: !! After fixing any errors, re-run the installer to complete the installation or upgrade. !!
        	2019-12-14T16:43:24.717+00:00 Running command: /opt/puppetlabs/puppet/bin/puppet agent --enable
        
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/host.rb:395:in `exec'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/helpers/host_helpers.rb:83:in `block in on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/shared/host_manager.rb:130:in `run_block_on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/patterns.rb:37:in `block_on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/helpers/host_helpers.rb:63:in `on'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:858:in `block in generic_install'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:800:in `each'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:800:in `generic_install'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:590:in `do_install'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:1391:in `block in install_pe_on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/structure.rb:300:in `confine_block'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:1374:in `install_pe_on'
      # ./.bundle/gems/gems/beaker-puppet_install_helper-0.9.8/lib/beaker/puppet_install_helper.rb:37:in `run_puppet_install_helper_on'
      # ./.bundle/gems/gems/beaker-puppet_install_helper-0.9.8/lib/beaker/puppet_install_helper.rb:8:in `run_puppet_install_helper'
      # ./spec/spec_helper_acceptance.rb:11:in `<top (required)>'
      # ./spec/acceptance/tasks/init_spec.rb:1:in `require'
      # ./spec/acceptance/tasks/init_spec.rb:1:in `<top (required)>'
      No examples found.
       
      Finished in 0.0001 seconds (files took 5 minutes 13 seconds to load)
      0 examples, 0 failures, 8 errors occurred outside of examples
      

      in https://jenkins-platform.delivery.puppetlabs.net/job/forge-windows_puppetlabs-reboot_intn-sys_full-pe-previous-master/PLATFORM=sles11-64default.a-redhat7-64mdca,WORKER_LABEL=beaker/190/console

      same issue in https://jenkins-platform.delivery.puppetlabs.net/job/forge-windows_puppetlabs-reboot_intn-sys_full-pe-previous-master/PLATFORM=sles12-64default.a-redhat7-64mdca,WORKER_LABEL=beaker/190/console

        2019-12-14T16:43:24.377+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Console_services[console-services]/Puppet_enterprise::Trapperkeeper::Bootstrap_cfg[console-services:console metrics-webservice]/Pe_concat::Fragment[console-services metrics-webservice]/File[/opt/puppetlabs/puppet/cache/pe_concat/_etc_puppetlabs_console-services_bootstrap.cfg/fragments/10_console-services metrics-webservice]: Skipping because of failed dependencies
        2019-12-14T16:43:24.378+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Profile::Console/Puppet_enterprise::Trapperkeeper::Activity[console-services]/Puppet_enterprise::Trapperkeeper::Bootstrap_cfg[console-services:activity activity-service]/Pe_concat[/etc/puppetlabs/console-services/bootstrap.cfg]/Exec[pe_concat_/etc/puppetlabs/console-services/bootstrap.cfg]: Skipping because of failed dependencies
        2019-12-14T16:43:24.378+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Profile::Console/Puppet_enterprise::Trapperkeeper::Activity[console-services]/Puppet_enterprise::Trapperkeeper::Bootstrap_cfg[console-services:activity activity-service]/Pe_concat[/etc/puppetlabs/console-services/bootstrap.cfg]/File[/etc/puppetlabs/console-services/bootstrap.cfg]: Skipping because of failed dependencies
        2019-12-14T16:43:24.379+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Pe_service[console-services]/Exec[pe-console-services service full restart]: Skipping because of failed dependencies
        2019-12-14T16:43:24.380+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Pe_service[console-services]/Service[pe-console-services]: Skipping because of failed dependencies
        2019-12-14T16:43:24.383+00:00 - [Error]: Could not prefetch pe_node_group provider 'ruby': Failed to open TCP connection to sounder-rifling.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "sounder-rifling.delivery.puppetlabs.net" port 4433)
        2019-12-14T16:43:24.425+00:00 - [Error]: Failed to apply catalog: Failed to open TCP connection to sounder-rifling.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "sounder-rifling.delivery.puppetlabs.net" port 4433)
        * /opt/puppetlabs/puppet/bin/puppet infrastructure configure  --detailed-exitcodes --environmentpath /opt/puppetlabs/server/data/environments --environment enterprise --no-noop --install=2018.1.12-rc0-87-g0447d96   
        * returned: 1
        2019-12-14T16:43:25.570+00:00 [ERROR]: !! There were problems during the application of the installation catalog. !!
        2019-12-14T16:43:25.576+00:00 [ERROR]: !! Review the logs at /var/log/puppetlabs/installer/2019-12-14T16.43.03+0000.install.log and resolve any issues you can find. !!
        2019-12-14T16:43:25.580+00:00 [ERROR]: !! After fixing any errors, re-run the installer to complete the installation or upgrade. !!
        2019-12-14T16:43:25.584+00:00 Running command: /opt/puppetlabs/puppet/bin/puppet agent --enable
       
      sounder-rifling.delivery.puppetlabs.net (redhat7-64-1) executed in 23.73 seconds
      Exited: 1
       
      An error occurred while loading ./spec/acceptance/tasks/init_spec.rb.
      Failure/Error: run_puppet_install_helper
      Beaker::Host::CommandFailure:
        Host 'sounder-rifling.delivery.puppetlabs.net' exited with 1 running:
         cd /tmp/2019-12-14_16.43.01.kjkmdz/puppet-enterprise-2018.1.12-rc0-87-g0447d96-el-7-x86_64 && ./puppet-enterprise-installer -y -c /tmp/2019-12-14_16.43.01.kjkmdz/pe.conf
        Last 10 lines of output were:
        	2019-12-14T16:43:24.379+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Pe_service[console-services]/Exec[pe-console-services service full restart]: Skipping because of failed dependencies
        	2019-12-14T16:43:24.380+00:00 - [Warning]: /Stage[main]/Puppet_enterprise::Console_services/Puppet_enterprise::Trapperkeeper::Pe_service[console-services]/Service[pe-console-services]: Skipping because of failed dependencies
        	2019-12-14T16:43:24.383+00:00 - [Error]: Could not prefetch pe_node_group provider 'ruby': Failed to open TCP connection to sounder-rifling.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "sounder-rifling.delivery.puppetlabs.net" port 4433)
        	2019-12-14T16:43:24.425+00:00 - [Error]: Failed to apply catalog: Failed to open TCP connection to sounder-rifling.delivery.puppetlabs.net:4433 (Connection refused - connect(2) for "sounder-rifling.delivery.puppetlabs.net" port 4433)
        	* /opt/puppetlabs/puppet/bin/puppet infrastructure configure  --detailed-exitcodes --environmentpath /opt/puppetlabs/server/data/environments --environment enterprise --no-noop --install=2018.1.12-rc0-87-g0447d96   
        	* returned: 1
        	2019-12-14T16:43:25.570+00:00 [ERROR]: !! There were problems during the application of the installation catalog. !!
        	2019-12-14T16:43:25.576+00:00 [ERROR]: !! Review the logs at /var/log/puppetlabs/installer/2019-12-14T16.43.03+0000.install.log and resolve any issues you can find. !!
        	2019-12-14T16:43:25.580+00:00 [ERROR]: !! After fixing any errors, re-run the installer to complete the installation or upgrade. !!
        	2019-12-14T16:43:25.584+00:00 Running command: /opt/puppetlabs/puppet/bin/puppet agent --enable
        
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/host.rb:395:in `exec'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/helpers/host_helpers.rb:83:in `block in on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/shared/host_manager.rb:130:in `run_block_on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/patterns.rb:37:in `block_on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/helpers/host_helpers.rb:63:in `on'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:858:in `block in generic_install'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:800:in `each'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:800:in `generic_install'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:590:in `do_install'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:1391:in `block in install_pe_on'
      # ./.bundle/gems/gems/beaker-4.14.1/lib/beaker/dsl/structure.rb:300:in `confine_block'
      # ./.bundle/gems/gems/beaker-pe-2.11.1/lib/beaker-pe/install/pe_utils.rb:1374:in `install_pe_on'
      # ./.bundle/gems/gems/beaker-puppet_install_helper-0.9.8/lib/beaker/puppet_install_helper.rb:37:in `run_puppet_install_helper_on'
      # ./.bundle/gems/gems/beaker-puppet_install_helper-0.9.8/lib/beaker/puppet_install_helper.rb:8:in `run_puppet_install_helper'
      # ./spec/spec_helper_acceptance.rb:11:in `<top (required)>'
      # ./spec/acceptance/tasks/init_spec.rb:1:in `require'
      # ./spec/acceptance/tasks/init_spec.rb:1:in `<top (required)>'
      No examples found.
       
      Finished in 0.00009 seconds (files took 5 minutes 13 seconds to load)
      0 examples, 0 failures, 8 errors occurred outside of examples
       
      /usr/local/rvm/rubies/ruby-2.4.3/bin/ruby -I/tmp/jenkins/workspace/forge-windows_puppetlabs-reboot_intn-sys_full-pe-previous-master/PLATFORM/sles12-64default.a-redhat7-64mdca/WORKER_LABEL/beaker/.bundle/gems/gems/rspec-core-3.9.0/lib:/tmp/jenkins/workspace/forge-windows_puppetlabs-reboot_intn-sys_full-pe-previous-master/PLATFORM/sles12-64default.a-redhat7-64mdca/WORKER_LABEL/beaker/.bundle/gems/gems/rspec-support-3.9.0/lib /tmp/jenkins/workspace/forge-windows_puppetlabs-reboot_intn-sys_full-pe-previous-master/PLATFORM/sles12-64default.a-redhat7-64mdca/WORKER_LABEL/beaker/.bundle/gems/gems/rspec-core-3.9.0/exe/rspec spec/acceptance failed
      Build step 'Execute shell' marked build as failure
      Set build name.
      New build name is '2.3.0-0228-223d715d'
      Recording test results
      Archiving artifacts
      [BFA] Scanning build for known causes...
      [BFA] Found failure cause(s):
      [BFA] PE-17015
      [BFA] Classifier fails to start up due to RBAC error from category Infrastructure-Suspected
      [BFA] Win10 Ent and 2019 agent module upgrade failure from category Infrastructure-Suspected
      [BFA] (QENG-7437) curl pipe tar unexpected end of archive from category Infrastructure-Suspected
      [BFA] (PE-27820) External postgres installation log has puppetdb connection failure warning from category Product-Suspected
      [BFA] Done. 138s
      [WS-CLEANUP] Deleting project workspace...[WS-CLEANUP] done
      Finished: FAILURE
      

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            david.schmitt David Schmitt
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support

                  Time Tracking

                  Estimated:
                  Original Estimate - 1 hour
                  1h
                  Remaining:
                  Time Spent - 40 minutes Remaining Estimate - 20 minutes
                  20m
                  Logged:
                  Time Spent - 40 minutes Remaining Estimate - 20 minutes
                  40m