Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10351

postgresql : weird behavior

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: postgresql
    • Labels:
      None
    • Environment:

      Puppet 6.11.1

      puppetlabs-postgresql (v6.3.0)

    • Template:
      MODULES Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 6.3.0
      Puppet Version: 6.11.1
      OS Name/Version:

      When using SCLs (Software Collections), and we specify the version (for example, to set postgresql::globals::data_checksums to true), it creates a problem because I see that in the debug output:

       

      Debug: Executing: 'systemctl status postgresql-12.1'

      It looks like it doesn't use the service_name parameter like in this execution:

      Debug: Executing: '/bin/systemctl is-enabled –- rh-postgresql12-postgresql'

      Puppet 6.11.1

      puppetlabs-postgresql (v6.3.0)

      Desired Behavior:

      It should exececute 'systemctl status rh-postgresql12-postgresql'

      Actual Behavior:

      **It executes 'systemctl status postgresql-12.1'

      That makes Puppet try to execute

       

      Please take a moment and attach any relevant log output and/or manifests. This will help us immensely when troubleshooting the issue.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ubellavance Ugo Bellavance
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support