Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10419

puppetlabs-iis : wrong output for net.tcp bindings

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: iis
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 4.5.1
      Puppet Version: 5.x
      OS Name/Version: Windows 2016

      when you set a net.tcp bindings if you provide the wrong value, debug message report a wrong :

      raise("bindinginformation for net.tcp protocol must be of the format '(ip|*):1-65535:hostname'")
      

      This is misleading because the value expected for this field is something like : 1-65535:hostname

      https://github.com/puppetlabs/puppetlabs-iis/blob/4.5.1/lib/puppet/type/iis_site.rb

      Desired Behavior:

      output should return the proper format expected by the module.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            romgo Hugo
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support