Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10610

postgresql : incorrect version range for concat dependency

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: postgresql
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Acceptance Criteria:
      Hide

      4.1.0 should be the minimum for concat

      Show
      4.1.0 should be the minimum for concat
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      The metadata for concat is as follows.

          {
            "name": "puppetlabs/concat",
            "version_requirement": ">= 1.1.0 < 7.0.0"
          } 
      

      https://github.com/puppetlabs/puppetlabs-postgresql/blob/master/metadata.json

      The code makes use of the force attribute which was added in concat 4.1.0.

      Desired Behavior:

      The version range for the dependency is correct.

      Actual Behavior:

      The module says it will work with ancient dependency versions and does not.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            ghoneycutt garrett honeycutt
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support