Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10670

puppet_agent: pc_repo misconfiguration on PE installations

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Accepted
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Team:
      Night's Watch
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Module Version: 6.15.0
      Puppet Version: 5.5.20
      OS Name/Version: RedHat 7.8

      Desired Behavior:

      pc_repo repository path should be configurable to honor package_version attribute

      Actual Behavior:

      pc_repo repository populates baseurl with pe_build_version() value, which doesn't take into account package_version. If package_version set to a particular version, say '5.5.19' and pc_repo sets baseurl to /packages/2018.1.15/ , which only has '5.5.20' package.

      IMHO, in addition to alternate_pe_source, a new attribute, alternate_pe_version, for example, should be added, so user can configure it appropriately and instead of  pe_build_version() by default use 'current' value, which will point to the version of the PE installed on the master

       

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            vchepkov Vadym Chepkov
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support