Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10673

puppet_agent : puppetlabs-facts 1.0 fails to meet dependencies

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Template:
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      NW - 2020-05-27
    • Method Found:
      Customer Feedback
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 3.1.0
      Puppet Version: PE 2019.5
      OS Name/Version: Reported on CentOS 6

      Desired Behavior:

      The latest 1.0 version of the puppetlabs-facts module, which is under our namespace but not a supported module, is an acceptable dependency of the latest puppetlabs-puppet_agent module.

      OR

      If there's a reason why puppetlabs-facts 1.0 is not acceptible, it is documented in the puppetlabs-puppet_agent README.

      Actual Behavior:

      After running puppet module list on the master, the following error code appears:

      ```
      Warning: Module 'puppetlabs-facts' (v1.0.0) fails to meet some dependencies:
      'puppetlabs-puppet_agent' (v3.1.0) requires 'puppetlabs-facts' (>= 0.5.0 < 1.0.0)
      ```

      See also the customer report at https://github.com/puppetlabs/puppetlabs-facts/issues/40

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              dorin.pleava Dorin Pleava
              Reporter:
              garrett.guillotte Garrett Guillotte
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support