Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10724

mysql : depends on unsupported modules

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: mysql, supported
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 10.6.0
      Puppet Version: 6.16.0
      OS Name/Version: Ubuntu 18.04

      As a supported module, mysql probably shouldn't depend on unsupported modules.

      Desired Behavior: Either don't depend on resource_api module or promote resource_api module and puppetserver_gem module to supported status.**

      Actual Behavior:

      mysql supported module depends on unsupported resource_api module. Seems like that either de facto makes resource_api (and its dependency puppetserver_gem) supported and it should be labeled as such, or it should not be a dependency.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            nabber00 Neil M
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support