Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10743

unable to upgrade the puppet agent(windows) from 6.4.2 to 6.14.0

    XMLWordPrintable

    Details

    • Type: CI Blocker
    • Status: Closed
    • Priority: Critical
    • Resolution: Won't Do
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
      None
    • Environment:

      Dev

    • CI Pipeline/s:
      pe-integration pe-2019.1.x
    • Team:
      Night's Watch
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      Hi All,My PE successfully upgraded fromĀ 2019.1.0 to 2019.5.0 but I am unable to upgrade my puppet agents (windows) from 2019.1.0 to 2019.5.0.followed the document:
      https://puppet.com/docs/pe/2019.5/upgrading_agents.html Latest MSI file is available in PE and agent as well (tried by installing the MSI manually, able to install the MSI: Version got changed to 6.14.0 as expected). Manually ran the puppet agent -t on agent, also getting the below error. Getting error :

      change from false to true failed: Failed previous installation with: ScriptHalted
      Source: /Stage[main]/Puppet_agent::Install::Windows/Puppet_agent_upgrade_error[puppet_agent_upgrade_failure.log]/ensure_notexist
      File: /etc/puppetlabs/code/environments/development/modules/puppet_agent/manifests/install/windows.pp
      Line: 41
      Failed previous installation with: ScriptHalted
      Source: Puppet
      

      kindly suggest your inputs to address this issue.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            vinay.kor vinay
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support