Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10791

Chocolatey : Increase upper boundary for powershell dependency to 5.0.0

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: chocolatey
    • Labels:
      None
    • Template:
      MODULES Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 5.1.0
      Puppet Version: 6.18.0
      OS Name/Version: Windows 10

      1. Create an empty directory
      2. Run puppet module install puppetlabs/powershell --modulepath <the_directory>
      3. Run puppet module install puppetlabs/chocolatey --modulepath <the_directory>

      Desired Behavior:

      The installation of the chocolatey module should work.

      Actual Behavior:

      The installation of the chocolatey module fails with:

      Error: Could not install module 'puppetlabs-chocolatey' (???)
        No version of 'puppetlabs-chocolatey' can satisfy all dependencies
          Use `puppet module install --ignore-dependencies` to install only this module
      

      The reason (most likely) is that the powershell module is now in version 4.0.0 but the chocolatey module defines its dependency on the powershell module as (>= 1.0.1 < 4.0.0) .

        Attachments

          Activity

            People

            Assignee:
            adrian.iurca Adrian Iurca
            Reporter:
            skrysmanski Sebastian Krysmanski
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support