Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10823

postgresql : dependencies of postgis missing

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: postgresql
    • Labels:
      None
    • Environment:

      CentOS 8 x86_64

    • Template:
      MODULES Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      *Module Version:*6.7.0
      *Puppet Version:*2019.8.1
      OS Name/Version: centos 8 (but also 7)

      Postgis won't install due to missing dependencies.

      Desired Behavior:

      With this script, postgis is installed:

      include 'postgresql::server::postgis'
      package { 'postgresql-postgis-utils':
      ensure => 'present',
      name => "${postgresql::params::postgis_package_name}-utils",
      }

      Actual Behavior:

      Error: Execution of '/usr/bin/dnf -d 0 -e 1 -y install postgis30_12' returned 1: Error:
      Problem: cannot install the best candidate for the job

      • nothing provides geos38 >= 3.8.1 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides proj71 >= 7.1.0 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides gdal31-libs >= %{gdalminorversion} needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libSFCGAL.so.1()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libproj.so.19()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides SFCGAL needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libgdal.so.27()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
        Error: /Stage[main]/Postgresql::Server::Postgis/Package[postgresql-postgis]/ensure: change from 'purged' to 'present' failed: Execution of '/usr/bin/dnf -d 0 -e 1 -y install postgis30_12' returned 1: Error:
        Problem: cannot install the best candidate for the job
      • nothing provides geos38 >= 3.8.1 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides proj71 >= 7.1.0 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides gdal31-libs >= %{gdalminorversion} needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libSFCGAL.so.1()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libproj.so.19()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides SFCGAL needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libgdal.so.27()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64

      Error: Execution of '/usr/bin/dnf -d 0 -e 1 -y install postgis30_12-utils' returned 1: Error:
      Problem: package postgis30_12-utils-3.0.2-1.rhel8.x86_64 requires postgis30_12 = 3.0.2-1.rhel8, but none of the providers can be installed

      • cannot install the best candidate for the job
      • nothing provides geos38 >= 3.8.1 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides proj71 >= 7.1.0 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides gdal31-libs >= %{gdalminorversion} needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libSFCGAL.so.1()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libproj.so.19()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides SFCGAL needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libgdal.so.27()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
        Error: /Stage[main]/Nominatim::Database/Package[postgresql-postgis-utils]/ensure: change from 'purged' to 'present' failed: Execution of '/usr/bin/dnf -d 0 -e 1 -y install postgis30_12-utils' returned 1: Error:
        Problem: package postgis30_12-utils-3.0.2-1.rhel8.x86_64 requires postgis30_12 = 3.0.2-1.rhel8, but none of the providers can be installed
      • cannot install the best candidate for the job
      • nothing provides geos38 >= 3.8.1 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides proj71 >= 7.1.0 needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides gdal31-libs >= %{gdalminorversion} needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libSFCGAL.so.1()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libproj.so.19()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides SFCGAL needed by postgis30_12-3.0.2-1.rhel8.x86_64
      • nothing provides libgdal.so.27()(64bit) needed by postgis30_12-3.0.2-1.rhel8.x86_64

      Proposed fix:

      Next to installing the repo for the specific postgresql version, also the common repo is needed: baseurl=https://download.postgresql.org/pub/repos/yum/common/redhat/rhel-$releasever-$basearch

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            wvravesteijn Wim van Ravesteijn
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support