Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-10977

{puppetlabs-puppet_agent} : {prerequisites_check.ps1}

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
    • Template:
      MODULES Bug Template
    • Team:
      Night's Watch
    • Story Points:
      1
    • Sprint:
      NW - 2021-03-31
    • Method Found:
      Needs Assessment
    • Release Notes:
      Not Needed
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: 4.4.0
      Puppet Version: v2019.8.4
      OS Name/Version: Windows

      Describe your issue in as much detail as possible...

      Desired Behavior:

      Installing on Windows requires us to have the ExecutionPolicy Bypass parameter.

      Code in 4.4.0 (manifest/install/windows.pp):

      {{ exec { 'prerequisites_check.ps1':
      command => "${::system32}\\WindowsPowerShell\\v1.0
      powershell.exe \
      -NoProfile \
      -NoLogo \
      -NonInteractive \
      ${_prerequisites_check} ${::puppet_agent::_expected_package_version} ${_msi_location} ${_logfile}",
      require => File[$_prerequisites_check]
      }}}

      And in master it is correct:

      {{exec { 'prerequisites_check.ps1':
      command => "${::system32}\\WindowsPowerShell\\v1.0
      powershell.exe \
      -ExecutionPolicy Bypass \
      -NoProfile \
      -NoLogo \
      -NonInteractive \
      ${_prerequisites_check} ${::puppet_agent::_expected_package_version} ${_msi_location} ${_logfile}",
      require => File[$_prerequisites_check]
      }}}

      Actual Behavior:

      Would like to see this in a release (we pin our Puppetfile to releases).

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              ralfb Ralf Bosz
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support