Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-11080

puppetlabs-firewall : Package conflict between ebtables and iptables in Arch Linux

    XMLWordPrintable

Details

    • Needs Assessment
    • Needs Assessment

    Description

      Basic Info
      Module Version: v3.0.0
      Puppet Version: 6.22.1
      OS Name/Version: Arch Linux

      The ebtables package no longer exists, and the ebtables command is now part of the iptables-nft package, which conflicts with the iptables package. Since the firewall module requires the ebtables command but also requires the iptables package, there's a conflict (see attached log using less -R).

       

      I've implemented a workaround which installs iptables-nft instead of iptables.

      Attachments

        Activity

          People

            Unassigned Unassigned
            l0b0 Victor Engmark
            Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support