Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-11185

puppetlabs-postgresql : fails to install RPMs in CentOS Stream 8, tries to install expiring version

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: postgresql
    • Labels:
      None
    • Environment:
    • Template:
      MODULES Bug Template
    • Method Found:
      Needs Assessment
    • QA Risk Assessment:
      Needs Assessment

      Description

      Basic Info
      Module Version: puppetlabs-postgresql (v7.4.1)
      Puppet Version: 7 
      OS Name/Version: CentOS Stream 8

      Running puppet agent with puppetlabs-puppetdb and puppetlabs-postgresql modules enabled results in an attempt to install postgresql96-server. If this is done without manually running  'sudo dnf y module disable postgresql' the run fails because it can't find the postgresql96-server RPM.

      Desired Behavior: install a reasonable default postgresql version

      Actual Behavior:

      failure to install postgresql RPMs of any type.

       

      Further, postgres96 is expring soon. It should install something that will be around for a while.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            nomad Lee Damon
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Zendesk Support