Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-11315

[puppet_agent] auto version parameter assumes puppet and puppet-agent versions are the same

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Normal
    • Resolution: Fixed
    • None
    • None
    • puppet_agent
    • None
    • On Centos 7

    • Phoenix
    • 1
    • Phoenix 2022-05-25
    • Needs Assessment
    • Bug Fix
    • Hide
      Fixes an issue with agent upgrades when the `package_version` attribute is set to "auto" and there is a discrepancy between the puppet-agent (AIO) version and Puppet version.
      Show
      Fixes an issue with agent upgrades when the `package_version` attribute is set to "auto" and there is a discrepancy between the puppet-agent (AIO) version and Puppet version.
    • Needs Assessment

    Description

      Hi,

      My puppet agent try to drowngrade to a non-existing release

      255:Debug: Runtime environment: puppet_version=6.27.0, ruby_version=2.5.9, run_mode=agent, default_encoding=UTF-8
      2582:Debug: Facter: fact "puppetversion" has resolved to "6.27.0".
      4282:Debug: /Stage[main]/Puppet_agent::Install/Package[puppet-agent]/notify: notify to Puppet_agent_end_run[6.27.0]
      4636:Debug: Package[puppet-agent](provider=yum): Ensuring => 6.27.0
      4639:Debug: Package[puppet-agent](provider=yum): Downgrading package puppet-agent from version 6.27.1-1.el7 to 6.27.0
      4640:Debug: Executing: '/bin/yum -d 0 -e 0 -y downgrade puppet-agent-6.27.0'
      4641:Notice: /Stage[main]/Puppet_agent::Install/Puppet_agent_end_run[6.27.0]: Dependency Package[puppet-agent] has failures: true
      4642:Debug: /Stage[main]/Puppet_agent::Install/Puppet_agent_end_run[6.27.0]: Resource is being skipped, unscheduling all events
      

      The possible cause

      $ rpm -qa puppet-agent
      puppet-agent-6.27.1-1.el7.x86_64
      $ puppet --version
      6.27.0
      

      After a downgrade of puppet-agent to 6.26.0 on the the puppet server the problem is fixed

      Notice: /Stage[main]/Puppet_agent::Install/Package[puppet-agent]/ensure: ensure changed '6.27.1-1.el7' to '6.26.0' (corrective)
      

      The puppet code that manage the agent update is basic

          class {'::puppet_agent':
            collection      => 'puppet6',
            package_version => 'auto',
            service_names   => ['puppet'],
          }
      

      Attachments

        Activity

          People

            michael.hashizume Michael Hashizume
            fs75 Fran├žois Scala
            Votes:
            1 Vote for this issue
            Watchers:
            12 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support