Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-11334

puppetlabs-puppet_agent : Agent download fails for older WIndows systems

    XMLWordPrintable

Details

    • Bug
    • Status: Resolved
    • Normal
    • Resolution: Fixed
    • None
    • None
    • None
    • None
    • Bolt
    • Needs Assessment
    • Needs Assessment

    Description

      Most modern sites either require or are starting to require TLS 1.2. On older Windows systems the default security protocols for PowerShell 5 are SSL3 and TLS 1.0.

      If using System.Net.WebClient, Invoke-WebRequest or Invoke-RestMethod to communicate with a site that has a higher TLS requirement requests will fail with the following error message:

      Could not create SSL/TLS secure channel.

      This was causing failures on our nightly test runs for Windows Server 2016.

      Attachments

        Activity

          People

            Unassigned Unassigned
            craig.gumbley Craig Gumbley
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:

              Zendesk Support