Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-1290

Warning: Found multiple default providers for vcsrepo: cvs, dummy, svn, git; using cvs

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: vcsrepo
    • Labels:
      None
    • Template:

      Description

      I'm getting this warning with the latest version of vcsrepo (1.1.0) using Puppet 3.6.2.

      This was originally reported in:

      It was also fixed here:

      https://github.com/puppetlabs/puppetlabs-vcsrepo/pull/35

      However it seems to be back with Puppet 3.6 (see the latest comments from the above pull request).

      I'm also wondering what's the point for having "default" provider. Why not just let the user decide it?

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned Unassigned
              Reporter:
              manum Manu Mäki
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Zendesk Support