Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-1807

ha-params with rabbitmq_policy does not work

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: rabbitmq
    • Labels:
    • Template:

      Description

      Using ha-params with rabbitmq_policy in the rabbitmq Puppet module does not work.

      If I use an integer for the value of ha-params, then the rabbitmq_policy definition validation will fail because it only accepts string values. If I use a string for the value of ha-params, then rabbitmqctl set_policy will reject the resulting JSON because the value of ha-params should be an integer.

        Attachments

          Activity

            People

            Assignee:
            Unassigned Unassigned
            Reporter:
            tobyhs Toby Hsieh
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support