Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-2005

Registry - Hyphen in Array causes random characters appended to value (failure in should_manage_values.rb)

    XMLWordPrintable

Details

    • Bug
    • Status: Closed
    • Major
    • Resolution: Won't Fix
    • None
    • None
    • registry
    • 2
    • Windows 2015-07-29

    Description

      Originally reported at https://groups.google.com/d/msgid/puppet-users/a0c424bc-665d-49ac-bc60-8d0f7c927db7%40googlegroups.com

      Attempting to create a registry value of type array does not work properly when a "-" is in one of the strings being added.

      registry_value { 'HKLM\Software\Microsoft\Rpc\Internet\Ports':
      	ensure => present,
      	type => array,
      	data => ['6500-7000']
      }
      

      Results in this:

      PS C:\Users\Administrator> Get-ItemProperty 'HKLM:\Software\microsoft\Rpc\Internet'
       
      Ports                  : {6500-7000, ?}
      

      Using the GUI to look at the registry, results in a bunch of random words and characters being appended to the end.

      Simply opening the registry value in the GUi and clicking OK without actually changing anything resolves this.

      I've tested this quite a bit trying to troubleshoot, and it seems specifically related to the dash / hyphen character being in the string.

      This is running Puppet 3.7.5 with Registry's latest version at the time of this writing (v1.1.0).

      Attachments

        Issue Links

          Activity

            People

              rob Rob Reynolds
              rob Rob Reynolds
              Ryan Gard Ryan Gard
              Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

                Created:
                Updated:
                Resolved:

                Zendesk Support