Uploaded image for project: 'Modules'
  1. Modules
  2. MODULES-2943

logical_volume/lvm.rb causes ASCII error on Solaris with locale set to C

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: lvm
    • Labels:

      Description

      Solaris 10 x86 with running (opencsw) puppet 3.7.4 with ruby 2.0 :
      LANG=
      LC_CTYPE=C
      LC_NUMERIC=C
      LC_TIME=C
      LC_COLLATE=C
      LC_MONETARY=C
      LC_MESSAGES=C
      LC_ALL=

      when running puppet causes the following error:
      Info: Retrieving plugin
      Error: invalid byte sequence in US-ASCII
      Error: /File[/var/lib/puppet/lib/puppet/provider/logical_volume/lvm.rb]/content: change from {md5}d24f8b9a2928dc94d9e820714a11c20a to {md5}95476cfb372e7c165a14c9a126ea9383 failed: invalid byte sequence in US-ASCII

      This error occurs when going from 0.5 of the lvm module to 0.6 of the lvm module.
      The lvm 0.5 version is fine.
      The error in question does not affect Solaris though (since it doesn't use lvm) other than constantly producing an error for each run

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            alpha Robert Rosengren
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Zendesk Support