Details

    • Type: Bug
    • Status: Closed
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: puppet_agent
    • Labels:
    • Template:
    • Team:
      Platform OS
    • Story Points:
      2

      Description

      We're unable to upgrade fedora with the puppet_agent module, due to yum requiring the fedora tag at the end of the package version (PUP-5802/PUP-5025). This shows up during an upgrade as:

      Error: /Stage[main]/Puppet_agent::Install/Package[puppet-agent]/ensure: change from 1.3.6-1.fedoraf22 to 1.4.2-1.el22 failed: Could not update: Execution of '/usr/bin/dnf -d 0 -e 1 -y install puppet-agent-1.4.2-1.el22' returned 1: Error: no package matched: puppet-agent-1.4.2-1.el22
      

      In order to resolve this, we should provide the "fedorafXX" value at the end of the version string.

        Attachments

          Activity

            jsd-sla-details-panel

              People

              • Assignee:
                Unassigned
                Reporter:
                brandon.high Brandon High
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:

                  Zendesk Support